Innovative Web Design and Application Development Forum

Thread #602

Portrait for pcpete

by: pcpete
September 1st, 2006
WT6 forgets settings every reboot
Ive been using WT for ages. Since upgrading to a couple years ago, every single time I reboot, WT6 starts up and goes through the whole configuration procedure again.
No matter what options I set (sounds, chime types, display type, just about every user setting), when I reboot, it is all forgotten.
I watched the worldtime.conf file in the data directory. When I make changes to any of the abovementioned settings, the file is updated with my settings. However, once I reboot (which is rarely, but it does happen), the worldtime.conf file is overwritten with a "default" file that magically appears from nowhere! Thus all the user-definable settings change.

I tried making all my changes, then when the file was saved, I shut down WT6 (properly!), and made the .conf file read-only... WT6 then crashed when starting. Somehow, it needs to be able to read the conf file, but gets all its internal knickers twisted and just overwrites the file for the hell of it.

This has happened since I upgraded in 2003 (I think it was then; much has changed), but Ive just put up with it as an annoyance; but if someone out there has any ideas how to fix this, I would be most appreciative!

Like others here, I love my ships bell chimes/Big Ben/etc, and its a real shame that the sounds paths also get confused on install, and only a few of the expected default sound files are included with the installation.
FWIW, Ive up- and down-graded till Im blue in the face; installed on many, many computers (as my hardware changed, the one thing that stays the same is WT!), and many OSes and innumerable service packs, hotfixes, etc.
This looks just like a startup logic problem/incorrect install package list issue, and Im sure it can simply and easily be fixed.
Uploaded Image
Data is not Information; Information is not Knowledge; Knowledge is not Wisdom

jamesbprincehorn has no photo

by: jamesbprincehorn
June 28th, 2018
WT6 forgets settings every reboot
I have taken the "remove WT6 and install WT5" advice to heart, but i can't get rid of WT6.  I have removed it, and it does NOT appear in the list of apps/programs on my Win7 desktop, but it still starts up each morning when I crank up the PC.  I get TWO splash boxes asking if i want to set my time, one on top of the other, i have to dismiss each separately.  

Do I need to investigate removing WT6 more, or can I install WT5 and ( hopefully ) it will overwrite the mysterious and invisible WT6 app?

Thanks to all who assist, I see that this problem has been around for a while, hoping there is new information out there.  


Portrait for vonhardenberg

by: vonhardenberg
August 28th, 2017
WT6 forgets settings every reboot
I am having trouble setting up a new clock. I enter Washington DC and set the clock, but when I shut down and reboot it disappears and is replaced with "New Location". I have downloaded the manual, but it doesn't explain how to lock in the new clock.
karleneeckhardt has no photo

by: karleneeckhardt
January 13th, 2014
WT6 forgets settings every reboot
As the discussion is going on WT6,and  the question is still partially answered I would like to add that either you should update it with the latest one because now a days so many company is providing a huge collection of software to make you free from such sticking problems.Google is launching so many apps to have things on your finger tip,the latest Google shared contact is one of them..For more such details

tempo101 has no photo

by: tempo101
July 19th, 2013
wt600941 presently used in Windows8
install .log Installing Applications
  coping worldtime.exe to C:Program Files PawPrint.netWorldTimeworldtime.exe  FAILED

under: Coping Path data there are 6 failed files using the same format as
Installing Applications.
1.wtalarms.wtd  2.wtclocks.wtd  3.wtdst.wtd  4.wtservers.wtd  5.wttraqdt.wtd
6.worldtime.conf     These 6 files failed plus the Installing Applications 1 file.
All other files loaded OK.
Any time you reboot you need to reload wt600941.exe.  I do not delete the old
version. It identifies it as version 5.5 and it saves the settings. Nice to have it
working in Windows 8.  
tempo101 has no photo

by: tempo101
July 18th, 2013
WT6 forgets settings every reboot
I am using wt600941.exe on Windows * (yes it can be done, not pretty, but it
works. I have tried to find WT6 beta copy, but either the link is dead or they
have dropped it. I have my own copy (saved in favorites /downloads) Any url
where the WT6 beta is downloadable? has no photo

July 2nd, 2013
WT6 forgets settings every reboot
Trying again, site keeps losing my text and making me type it again. (Database Error:
Please provide the following information to a site administrator, unfortunately your request can not be completed at this time.

5.5.14 (mysqli) :: MySQL server has gone away)

I'm not sure if anyone looks here, nothing has been posted in many years on this problem, but i suddenly started for me.

I've tried the fixed listed on the thread, but none helped.  Is that any NEW info on this?

JBP has no photo

July 2nd, 2013
WT6 forgets settings every reboot
I'm not sure if anybody looks here, it appears that nothing has been posted in several years, but I'll try.  WT6 ran great for me for many years, but suddenly I'm having this problem.  

I've tried the "solutions" listed, but for various reasons none worked.  For example, I tried the fix with "ipoint" but I don't a file by that name on my computer.
Portrait for steffo

by: steffo
October 5th, 2008
WT6 forgets settings every reboot
Ive had the same problem for quite some time till I found a workaround: just before turning off your computer, right click on the WT6 icon and exit the program. Wait for the icon to disappear before turning off your computer and the settings will be there as you left them next time you reboot.
Thats working for me, I hope it will for you too!
craigs has no photo

by: craigs
October 5th, 2008
WT6 forgets settings every reboot
I have a similar problem with WT5 running on XP. Each time it reboots, the location of the clocks changes to positions where I dont want them. It seems to put the last clock added at the far right - even if I have selected "Sort by time zone". Any clues as to how to correct this ?
paulg has no photo

by: paulg
June 5th, 2007
WT6 forgets settings every reboot
I seem to remember having this problem in the past with an XP system.
As I recall it had to do with the fact that the Location and Start pathes
of the shorcut used to start the program were not pointing to the correct
WorldTime directory. I think it had something to do with the way I ran the
install program and the fact that it does an extraction and then offers to
run the setup program.

Portrait for pcpete

by: pcpete
June 3rd, 2007
WT6 forgets settings every reboot
Ive also found that moving startup items around may help in some cases.

A great (read: brilliant) autorun tool is available for free at
This shows every single startup application, and where its called from. You may also be able to rearrange the startup so WT6 starts first (or last).

Despite being able to nominate where ST6 runs, on my new system (XP64) it always dies no matter where I put it, so my workaround is still WT5.

It would have been nice if one of the developers had been able to investigate this behaviour to see what the mechanism is when WT6 "drops its load", because the only reason I can think of is if one or more shared DLLs that WT6 relies on are either changed or moved, or else a config file is corrupted, and that should be irrelevant to any Windows app (after all, most apps ask the OS for the path to the desired shared dll, they should never specify the path, and the same goes for config files - if they lose the config, they should rebuild it without scrambling their settings completely). But then, Im just a user, not the developer. Sigh.
Data is not Information; Information is not Knowledge; Knowledge is not Wisdom
utrying2 has no photo

by: utrying2
June 3rd, 2007
WT6 forgets settings every reboot
I think I found out what causes WT6.xx to lost its settings.  I too recently began to experience this issue.  I ran MSCONFIG, in there, ipoint.exe started up at startup just like, I decided to uncheck ipoint.exe and guess what it seem  to have stop the problem.  But this executable is part of the Microsoft mouse driver.  So you need to decide which is more important, the mouse driver or  
Portrait for pcpete

by: pcpete
September 2nd, 2006
WT6 forgets settings every reboot
Ha! Ive solved the problem!

Its a patch called "World Time 5.5" :)

Seriously, Im rebooting a bit lately with new CPUs and sound cards and RAID installs, and I just got tired of continually resetting WT6. So I got rid of it, and installed WT5. Hey presto!

Advantages gained :
1) Doesnt reset all settings on every reboot or logout
2) I get ALL the sounds
3) I save 3-5 minutes every reboot/logout
Cant really see any. I still get the tools I use every day (stopwatch, date calcs, etc), and while theyre not as pretty or useable as WT6, they work!
Sorry to waste so much bandwidth. And thanks to those who suggested (in other threads) going back to WT5...

PC (Perpetually Clocking) Pete
Data is not Information; Information is not Knowledge; Knowledge is not Wisdom

RSS feed Feed Description
Subscribe to the complete Forum RSS forum feedFull RSS feed Complete RSS feed
Subscribe to the complete Forum RSS forum feed for this category onlyWorldTime Support RSS feed for: WorldTime Support
A Rich Site Summary (RSS) feed is an xml data file that provides a summary of the information contained here. It is not designed to be viewed in your browser, but instead by rss reader software. If you do not know what this means - you can safely ignore it, as it is provided for advanced users with rss reader software only.

To contribute to our forums you must login. New members can register for a user account.

Copyright © 1992-2024
web design and maintenance: